1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Where we are now: The site is back up and running! The character set encoding issue has been fixed so old posts should now look ok. I am currently working on themes/skins etc and I will be deleting the temporary green skin very soon as it has many issues. I will do a very quick variation on the stock blue skin first just to get a light-grey background and san-serif font, and I will set this as default. Later this week I will hopefully add a professional third-party skin in pfm colours (life is way too short to do this crap myself, and I've found one I really like than needs next to no tweaking). We are getting there slowly...
    Dismiss Notice
  3. May I please request people check and update their email address if it is out if date. I ask as I’m getting countless bounce errors as the server fails to send notifications through etc. I’ll eventually figure out how to send these to a black hole somewhere, but it makes sense to address it at source as quite a few folk are obviously not getting the thread and conversations notifications they have set in their preferences.
    Dismiss Notice
  4. Things you need to know about the new ‘Conversations’ PM system:

    a) DO NOT REPLY TO THE NOTIFICATION EMAIL! I get them, not the intended recipient. I get a lot of them and I do not want them! It is just a notification, log into the site and reply from there.

    b) To delete old conversations use the ‘Leave conversation’ option. This is just delete by another name.
    Dismiss Notice

Pre Raspberry Pi delivery question please.

Discussion in 'audio' started by kennyh, Feb 6, 2017.

  1. kennyh

    kennyh pfm Member

    In LMS at the top right. The dropdown has 2 things in it. 1) Choose player, 2) your player has not been found.
     
  2. Man in a van

    Man in a van pfm Member

    I have to go out for a bit now Kenny.

    if you do the above that should get you going, but I don't think you have the MDac properly configured on th Squeezelite settings page.

    I'll pick up with you later.

    Ronnie
     
  3. s1h1

    s1h1 performing within expectations

    kennyh, check squeezelite is running in piCorePlayer settings.

    btw, if swapping between IQaudIO and USB outputs, then it is possible to leave the Audio Output as IQaudIO, and switch Output Setting between IQaudIO and MDAC in the piCore Squeezelite settings page. This saves having to reboot the player to switch.
     
  4. s1h1

    s1h1 performing within expectations

    You need to add a User command in the tweaks page

    /mnt/mmcblk0p2/tce/squeezelite-armv6hf -n "Lounge_d2" -o sysdefault:CARD=hiFace -a 80:4::: -m b8:27:eb:07:7f:a9 -s 192.168.178.134

    The important thing here is to specify a new unique MAC to this player.
    The -s option binds my second instance of squeezelite to my Roon server.
     
  5. kennyh

    kennyh pfm Member

    Ronnie, many thanks for that, I'll be giving that a go now. Waiting in for a UPS delivery anyway so nothing else spoiling. Thanks again.






    Great advice, appreciated. Squeezlite seems to be running, at least it says it is. re Switching between IQ and MDAC in the ipcore/SL page, MDAC does not appear there, I select USB instead.

    However MDAC appears in the Alsamixer settings as an option.

    Chops54 may be right, maybe I should get back to the CD player:rolleyes:

    Thanks lads for the help.
     
  6. kennyh

    kennyh pfm Member

    Just as an aside. I don't know if it has any bearing on the problems I'm having, but often when I'm in ipcoreplayer and I press for instance squeezelite settings, wifi settings, LMS etc, the screen goes white and says "cannot connect". A few minutes later it'll be fine.

    I'm wondering if something is corrupted? Or maybe my new "home plugs" have a fault. they seem ok though.
     
  7. Man in a van

    Man in a van pfm Member

    Thanks for that, I had seen that line, but thought there was more to do.

    I'll give it a go later, when I have some spare time.

    ronnie
     
  8. kennyh

    kennyh pfm Member

    Well I've made a weapons grade bollocks up with this, nothing is working now.

    Deleted LMS as a last resort and even that is giving me grief now trying to log in....totally stuffed.

    What is the score now lads? Write a new card? as I bet I've a heap of old crap on this one festering away, or is it still saveable with this one.

    Next time this little bugger plays the slightest scrap of music I'll be leaving well alone :D

    Do you have a helpline number Ronnie :D
     
  9. Man in a van

    Man in a van pfm Member

    if you burn a new image, first give the card a quick format with

    https://www.sdcard.org/downloads/formatter_4/

    run as administrator and click on Option, and set Format size adjustment to "on"

    Can't help too much at the mo, I'm a bit busy, sorry.
     
  10. kennyh

    kennyh pfm Member

    Guys, flashed a fresh card this morning. That seems to have stopped the white screen saying "can't connect to site" every time I click a tab in Ipcore, and also it has stopped LMS and Squeezelite crashing all the time.

    Final thing now and I flooked it last time is how to get Tidal to show in the "my apps" section of LMS home. I've selected it on the apps page, entered details etc and it shows on my apps. Yet when I'm on the home page it is not there.

    Tried everything to no avail.

    Cheers
     
  11. Man in a van

    Man in a van pfm Member


    Did you do this?

    Also a LMS restart or picoreplayer reboot sometimes helps
     
  12. Man in a van

    Man in a van pfm Member


    MySqueezebox.com>My Apps>Tidal>Player Settings>Status>Home


    Uselesstechnophobe indeed :p what you like?
     
  13. kennyh

    kennyh pfm Member

    Struggling Ronnie to be honest..........It's hovering over the pedal bin at the moment by its Power chord :D

    Logged in to LMS, even changed passwords to make sure all was ok. Installed Tidal app (a million f***ng times) and entered email address for Tidal and password. My apps say I have installed yet it just wont show on the Tidal home page under my apps.

    Cheers mate!
     
  14. Man in a van

    Man in a van pfm Member

    Have you tried just pulling the plug and then re-powering?
     
  15. kennyh

    kennyh pfm Member

    Tried everything now Ronnie honestly. The bloody app button has vanished from the home page of LMS now too. I just about concede defeat with this experiment.

    Thanks again, as always appreciate the help.
     
  16. kennyh

    kennyh pfm Member

    Gave it one last try Ronnie, entered passwords and everything just like before and bingo, it's working again.

    Now I think I made a mess of things last time trying to get the MDAC to work with the RPI, which I actually did.

    I'm set up back to square one now with RPI/IQ dac+ working perfectly.

    Can I get the MDAC running side by side the IQaudio dac without hassles do you reckon?

    Some blokes talk about using a digi card for connecting to a remote dac.
    Is this where I went wrong, I was just using the USBs on the RPI's motherboard.

    Thanks.
     
  17. Del monaco

    Del monaco pfm Member

    I was a little worried there Kenny. Glad you got it going again though.
     
  18. kennyh

    kennyh pfm Member

    Cheers Del. What does a digi board do mate? Do I need one in reality to hook up to the MDAC or can I just usb the MDAC in to the rpi motherboard?
     
  19. ChrisPa

    ChrisPa pfm Member

    Take a copy of the SD card on your PC in this configuration. This is your backup.

    You can then reflash this if you run into further problems, without having to go right back to a clean installation
     
  20. Man in a van

    Man in a van pfm Member

    you can use either to connect to the MDac, suggest you look for instructions on how to connect the dac, there are a few threads on here on what to do.

    Really good advice this;

    https://www.raspberrypi.org/forums/viewtopic.php?p=239331

    it is possible to run the two together, if you can waita few days I'll try a setup and do a tutorial for you (unless anyone else comes along and shows you how)

    I would concentrate on getting the dac to work properly via the usb.

    I have an mydac here now and can do a few screen shots tomorrow with a bit of luck. (Again there must be folk reading this who have done it already, I think the MDAC is a bit particular in the usb side of life :eek: ).

    ronnie

    I have a digi board you can borrow if you want.


    Read here, from post#213 and down

    http://www.pinkfishmedia.net/forum/showthread.php?t=131922&page=15
     

Share This Page