Advertisement



  1. Things you need to know about the new ‘Conversations’ PM system:

    a) DO NOT REPLY TO THE NOTIFICATION EMAIL! I get them, not the intended recipient. I get a lot of them and I do not want them! It is just a notification, log into the site and reply from there.

    b) To delete old conversations use the ‘Leave conversation’ option. This is just delete by another name.
    Dismiss Notice

When is a disc clone not a clone?

Discussion in 'off topic' started by Darth Vader, Apr 7, 2020.

  1. Darth Vader

    Darth Vader From the Dark Side

    For years I have been cloning disc drives either to move to a bigger drive or to an SSD without any problems so guess my surprise when a simple clone failed to boot!

    For fun I've created a 'Windows-2-Go' USB drive. This was a clone of an existing Windows 10 Pro installation complete with activated software such as Microsoft Office Pro 2019 and the idea is that I can boot this on practically any other donor computer so can take my 'computer' with me in a small package. I have a few 250/500GB disk drives getting on for around 9 years old left over from various upgrades so built my win2Go on one of these. I have tried it on both a 9 yo Dell with a simple BIOS and a much more modern UEFI machine and I can boot on both without making any changes to BIOS/UEFI Yippee! So in case this old drive dies or I screw up somehow I cloned this to another spare drive. My goto free partition application has 'updated' since I last used it and told me that the cloning function with which I was familiar was now only available in the paid for 'Pro' version so after checking the web got a free copy of Macrium Reflect 7 and cloned the drive.

    It didn't boot - o/s not found. Comparing original disc against the cloned version it looked identical except the boot partition was not marked bootable, Huh? So I marked it bootable and tried again. This time it started to boot until a Windows blue screen telling me that it couldn't find winload.exe. Of course its there and under the correct path so what is going on? It can only be that cloning is no longer a disk bit copy operation.

    I wrote my first bit copier around 40 years ago for the BBC micro so that I could clone games disketes such as Elite. I later wrote a commercial bit copier for a US computer company when I was employed by them for their flagship huge hard disk - all 39MB yep that was huge 40 years ago and was the size of a washing machine. So I made what must have been a bad assumption in equating a bit copier with a modern cloner.

    It just so happens that I have an old disk duplicator docking station. So after blowing the dust of 'cloned' the Win2Go disk to another disk using the duplicator and it worked.

    I raise this in case others come across cloning problems. When I have time I'll check through other free cloners and see if they can cope. However what is for sure is that these cloners are not duplicating a disk using a bit copy function unlike my disk duplicator and the bit copier programs that I wrote decades ago.

    Cheers,

    DV
     
    Sue Pertwee-Tyr likes this.
  2. vince rocker

    vince rocker pfm Member

    Clonezilla works for me when I need it, which isn't often TBH.
     
    davidsrsb likes this.

Share This Page





Advertisement


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice