Advertisement



  1. Things you need to know about the new ‘Conversations’ PM system:

    a) DO NOT REPLY TO THE NOTIFICATION EMAIL! I get them, not the intended recipient. I get a lot of them and I do not want them! It is just a notification, log into the site and reply from there.

    b) To delete old conversations use the ‘Leave conversation’ option. This is just delete by another name.
    Dismiss Notice

Picoreplayer nas drive mount help! :(

Discussion in 'audio' started by Hayche, Apr 21, 2018.

  1. Hayche

    Hayche pfm Member

    Alright folks

    I can't for the life of me get my nas to mount. I had problems in the past when I last tried a pi but managed to get it working but not understanding how it worked!
    I have a seagate nas with 2 folders on it , one is named hayche and is private ,the other is named Public and is of course public ;)
    My music is in Public/flac/
    In picoreplayer I am putting shared as mount ,Public as Shared name ,the ip of my nas and user and pass I have tried blank ,as guest and also used my user and pass for the private folder. All to no avail!!

    Does anybody know what i am doing wrong ?

    Cheers
    Howard
     
  2. Tw99

    Tw99 source last

    NFS or SMB ?
     
  3. Hayche

    Hayche pfm Member

    I have used the default CIFS. Again I do not understand which it should be on :(

    Cheers
     
  4. slavedata

    slavedata pfm Member

    smb is more likely
     
  5. Marchbanks

    Marchbanks Hat and Beard member

    I only succeeded in doing this myself after a lot of trial and error. Looking at my settings now I would try Public/flac as the share name. I have simply put 1 in both user and pass. I have CIFS selected from the share type dropdown.
     
  6. garyi

    garyi leave blank

    Try 'Guest' in user name and no password.
     
  7. WAD62

    WAD62 pfm Member

    I use a QNAP NAS as a source for my picoreplayer/LMS installation...

    Parameters are;

    'ip addess', 'qmultimedia'(default media folder in the shared folder), CIFS, admin, 'admin password' (usually default is 'admin')

    With nothing set in options...

    Can you see your NAS folder via a network attached laptop?

    How do you log onto your NAS for management purposes?
     
  8. Hayche

    Hayche pfm Member

    Hi. Yes I can access the nas from various computers. It is shown as an icon under network and shows up as a drive. I can also access it via Web browser by in putting the local ip 192.168.0.44 ,this prompts me for my user and password to access the nas software. That is the same ip I am using in picoreplayer
    Tried eveything mentioned above with no luck yet.
    Thanks for the help so far.

    Howard.
     
  9. chiily

    chiily PFM Special Builder

    Are you using the newest version of piCoreplayer, 3.5? This version requires SMB v3 on the NAS.

    For the DS216 I have. I enter into picoreplayers GUI the NAS's IP addr, the share name which I shared amongst all the users on the NAS for r/w, one of the usernames and their password. Check the 'enable share' button and save.
     
  10. Guest432

    Guest432 Guest

    Have you enabled SMB v3 on your NAS?
     
  11. Guest432

    Guest432 Guest

  12. Hayche

    Hayche pfm Member

    Thanks folks. All working now by adding vers-1.0 in the options.
    Now for the mdac usb problem.
     
  13. Man in a van

    Man in a van pfm Member

    Answer not required :)
     
  14. WAD62

    WAD62 pfm Member

    Try a hub, or even better a USB re-gen device, I use an iFi but there are cheaper options...
     
  15. Stuart Frazer

    Stuart Frazer pfm Member

    I'm bumping this thread. I need help to connect my QNAP to a RPi 3b running piCorePlayer and LMS. I have been trying to do this for days now.

    LMS is installed and I've disabled Squeezelite, as I just want to use it for LMS as a pure music server. RPi is connected to the router with Ethernet cable. I have tried NFS and CIFS, but cannot get piCorePlayer to connect to the QNAP NAS where my music is stored in the Multimedia/Music folder.

    I have installed and enabled to additional file systems setting:

    [​IMG]

    I have tried to connect to the QNAP with both NFS and CIFS without success. I'm not sure what the best/easiest method is? This is my NFS attempt settings:

    [​IMG]

    The Write to Mount gives me an Error each time:

    [​IMG]
     
    Last edited: Nov 6, 2020
  16. Tw99

    Tw99 source last

    Can't see the pics/attachments. Either NFS or CIFS should work if they're configured properly. The problems are often to do with credentials, which is where testing access to the QNAP from another system might help. Can you access the QNAP share from a Windows machine for example ? If you can, then it ought to work from Picoreplayer if you use the same credentials.
     
  17. Stuart Frazer

    Stuart Frazer pfm Member

    Thanks for replying. I will try and fix the pics link to my setting in my post.

    I am hopelessly out of my depth here with the QNAP. I had a QNAP 2-bay previously which I used with LMS installed on that before QNAP pulled the LMS app. I've since upgraded to a 6-bay and I thought going to a RPi as the server would be the easiest way to set it up, but it's not as easy as I hoped.

    I can access the QNAP Folders and Files no problem using Windows File Explorer. Are there any other checks I can do?
     
  18. Man in a van

    Man in a van pfm Member

    @Stuart Frazer

    Hang on a bit I just need to fire up my qnap nas

    ronnie

    There is a share to edit on the NAS first
     
  19. Man in a van

    Man in a van pfm Member

    @Stuart Frazer

    I put my music files in a created Share called Squeezebox, so just substitute names

    The path might be different as I have an old TS121

    Navigate to Control Panel > Shared Folders >

    I tick the box on Squeezebox > Then the Edit Shared Folder Permissions (center hands icon on the rhs).

    Click > Add > Enter IP Address > Apply > Close > Exit


    [​IMG]

    back with the piCore bit shortly

    ronnie
     
    Stuart Frazer likes this.
  20. Marchbanks

    Marchbanks Hat and Beard member

    Just for comparison...

    I don’t have a /Volume1/ in my PCP sharename (although it is used by Windows) just the final folder name. I also have uid=1001,gid=50 as additional options, and 1.0 (rather than just 1) as my Samba version. I’m using CIFS.
     
    Stuart Frazer likes this.

Share This Page





Advertisement


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice