1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Where we are now: The site is back up and running! The character set encoding issue has been fixed so old posts should now look ok. I am currently working on themes/skins etc and I will be deleting the temporary green skin very soon as it has many issues. I will do a very quick variation on the stock blue skin first just to get a light-grey background and san-serif font, and I will set this as default. Later this week I will hopefully add a professional third-party skin in pfm colours (life is way too short to do this crap myself, and I've found one I really like than needs next to no tweaking). We are getting there slowly...
    Dismiss Notice
  3. May I please request people check and update their email address if it is out if date. I ask as I’m getting countless bounce errors as the server fails to send notifications through etc. I’ll eventually figure out how to send these to a black hole somewhere, but it makes sense to address it at source as quite a few folk are obviously not getting the thread and conversations notifications they have set in their preferences.
    Dismiss Notice
  4. Things you need to know about the new ‘Conversations’ PM system:

    a) DO NOT REPLY TO THE NOTIFICATION EMAIL! I get them, not the intended recipient. I get a lot of them and I do not want them! It is just a notification, log into the site and reply from there.

    b) To delete old conversations use the ‘Leave conversation’ option. This is just delete by another name.
    Dismiss Notice

Rega Planar 3 Motor replacement

Discussion in 'd.i.y.' started by chrisallan, Dec 8, 2008.

  1. chrisallan

    chrisallan Go on - bodge it!

    I've dug out the old Rega 3 and after hooking up some Naim phono boards to a couple of Avondale TPRs, I was settling in to a nice evening of music.
    I got distracted and left the platter on for a couple of hours before realising it had come to a stop. Looking at the motor, it had some black marks on the base looking like it had run dry. Even without the pulley on it, it wasn't turning properly.

    Is there a drop in replacement from a manufacturer or do I have to get the real deal from Rega, Ebay or Origin Live etc?

    I apologise to Mick Parry in advance for not toeing the line, being a cheapskate bodger, left wing soldering agitator and not immediately considering an LP12.

    I could be persuded to look at other TTs - I'm well out of touch with the spinning black vinyl world.
     
  2. hifi_dave

    hifi_dave Hi-Fi Retailer

    Are you certain that the motor is faulty ? Because I have never encountered a duff Rega motor, though the associated PCB sometimes fails. If it is the older version with a large resistor, check that the resistor hasn't got a burnt black ring around it.

    A replacement motor, pulley and PCB is £48.
     
  3. chrisallan

    chrisallan Go on - bodge it!

    I think it had run dry - hence the bits of black on the motor around the spindle. It seemed to run fast and slow and would judder. Can the bearings get rusty?
    I changed the resistor some years ago to a high power type.
     
  4. hifi_dave

    hifi_dave Hi-Fi Retailer

    I'm not sure as I've never seen a faulty one. Perhaps if it's been stored somewhere damp for a while it could corrode. You could try dripping a tiny drop of light oil into the motor from around the shaft. That might help.
     
  5. stevec67

    stevec67 pfm Member

    I have a P3 complete with no arm, the arm drilling is modified to take a different arm. It's all in good order and it's yours for less than a new motor, so you get a spare bearing, lid, all the bits. PM me if you'd like it, I want the space and don't want to start on Ebay.:)
     

Share This Page