1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Where we are now: The site is back up and running! The character set encoding issue has been fixed so old posts should now look ok. I am currently working on themes/skins etc and I will be deleting the temporary green skin very soon as it has many issues. I will do a very quick variation on the stock blue skin first just to get a light-grey background and san-serif font, and I will set this as default. Later this week I will hopefully add a professional third-party skin in pfm colours (life is way too short to do this crap myself, and I've found one I really like than needs next to no tweaking). We are getting there slowly...
    Dismiss Notice
  3. May I please request people check and update their email address if it is out if date. I ask as I’m getting countless bounce errors as the server fails to send notifications through etc. I’ll eventually figure out how to send these to a black hole somewhere, but it makes sense to address it at source as quite a few folk are obviously not getting the thread and conversations notifications they have set in their preferences.
    Dismiss Notice
  4. Things you need to know about the new ‘Conversations’ PM system:

    a) DO NOT REPLY TO THE NOTIFICATION EMAIL! I get them, not the intended recipient. I get a lot of them and I do not want them! It is just a notification, log into the site and reply from there.

    b) To delete old conversations use the ‘Leave conversation’ option. This is just delete by another name.
    Dismiss Notice

itunes problem

Discussion in 'audio' started by Interzone, Apr 22, 2012.

  1. Interzone

    Interzone pfm Member

    I have a mac mini in my second system that accesses music from the mini in my main system (ie the mini in the main system acts as a NAS for the one in the second system).

    It all works absolutely perfectly unless I try to use the remote app on the mini in the second system. And more specifically only when I use remote immediately after starting up the machine* in the second system. I simply get 'an unknown error occured. check your library and try again'. If I then screen share and look at itunes the correct song is selected but is not playing and has an exclamation mark next to it. If I then select the song via itunes it plays as normal and remote works from that point onwards. Any ideas?

    *or at least if itunes has not been accessed directly since start-up
     
  2. garyi

    garyi leave blank

    Your problem is that your external mini is not awake quick enough, so your local mac minis itunes library thinks the music has gone missing.

    Are you using the home sharing facility or are you mounting the other mini as a drive for itunes locally?
     
  3. Interzone

    Interzone pfm Member

    The mini with the music on is on 24/7. Just home sharing. As I said it works perfectly as long as I have accessed iTunes directly at some point.
     
  4. Cereal Killer

    Cereal Killer fourhundredandthirtytwo

    Defo a wake up issue of some sort.
     
  5. Interzone

    Interzone pfm Member

    It doesn't matter how long the machines have been on, if I try to access music using remote for the first time since startup on the second mini i get the error code but if I do it directly (via screen share or otherwise) it plays perfectly immediately and remote then works 100%.
     
  6. Cereal Killer

    Cereal Killer fourhundredandthirtytwo

    OK, so is it the remote ap timing out? Maybe you have an DHCP/IP conflict?
    Have you tried creating static MAC/IP addresses for the whole system?
     
  7. Interzone

    Interzone pfm Member

    They all have fixed IP (everything on the network does as my router has IP reservation so even if the device uses dhcp it always defaults to the same IP). As I said it's only when using remote for the first time after startup. Somehow remote can't find the music on the other machine but a mouse click in the same iTunes window can. and this allows remote to function properly.
     
  8. pocketkitchen

    pocketkitchen Registered User

    I'm afraid that this is an iTunes issue that can't be fixed any way other than ensuring that the drive containing the music is woken before the remote device tries to access it. If you go into iTunes>Preferences>Advanced you'll see that the iTunes music folder location has changed to whatever the default folder that the program normally uses. It's a bummer but there's no way round it. I have this all the time with my rather more standard Mac mini/NAS combination. Once you forget and start iTunes before mounting the drive, the folder changes and you have to re-do it. Pain in the arse. A different music client is the only way as far as I'm aware.
     
  9. Cereal Killer

    Cereal Killer fourhundredandthirtytwo

    Have you checked the IP's recently?
     
  10. Interzone

    Interzone pfm Member

    Thanks for the info. I tend to just use vnc to access iTunes for the first time then use remote after that so it's not massive issue but it was annoying me that I might have something set up wrong.
     
  11. Interzone

    Interzone pfm Member

    Yes.
     
  12. deltaunit

    deltaunit volume reveals detail

    Is the 2nd Mini trying to access the library on the 1st HD directly or sharing through iTunes so it appears in the sidebar?
     
  13. Interzone

    Interzone pfm Member

    When I selected the iTunes folder for the second mini I just found the music folder on the 1st via finder.
     
  14. Cereal Killer

    Cereal Killer fourhundredandthirtytwo

    Can't you select it on the first and play it on the second like a DLNA renderer?
     
  15. deltaunit

    deltaunit volume reveals detail

    Think this is wrong, you don't need a library setup for Mini 2. The first library should just appear in the sidebar under Shared.
     
  16. Interzone

    Interzone pfm Member

    Thanks. I'll check it out.
     
  17. Interzone

    Interzone pfm Member

    It does and there is access via my iPad. Damn, never knew you could do that, thanks!
     
  18. Interzone

    Interzone pfm Member

    I've just realised that I effectively announced I'm retarded on a public forum. God I'm so, er, retarded.
     
  19. deltaunit

    deltaunit volume reveals detail

    A lot of Apple problems seem to be come down to them making things far to too simple to 'just work'. You expect there to be some complicated setup or configuration so it's easy to miss that it's already working on its own devices.
     
  20. Interzone

    Interzone pfm Member

    True. Thanks for the help. Appreciated. :)
     

Share This Page